ANCM not reading “ASPNETCORE_ENVIRONMENT” variable from local environment.

  • Thread starter Ramchandra_Kudtarkar
  • Start date
R

Ramchandra_Kudtarkar

After upgrading the asp.net core application to asp.net core 3.1 version, application is not able to read the “ASPNETCORE_ENVIRONMENT” variable from local environment and getting defaulted to web.config values.



ASPNETCORE_ENVIRONMENT value is set as Development in Web.config.









ASPNETCORE_ENVIRONMENT value is set as Production in local environment of Azure App Service application setting.









ANCM is Preferring value set in Web.config over the local environment variable in Azure App service application setting.









Solution:



We need to add a switch “ANCM_PREFER_ENVIRONMENT_VARIABLES” and set as “true” to allow ANCM to prefer the local environment over the Web.config values. Below is the screenshot of app service app settings.







If the switch is added in both Web.config and local environment and both of them are set to "true" then web.config "ASPNETCORE_ENVIRONMENT" will take precedence.



After setting “ANCM_PREFER_ENVIRONMENT_VARIABLES” as “true” in App service App settings, ANCM is preferring the local environment variable "ASPNETCORE_ENVIRONMENT" which is set to production .







For more information about these changes, please refer below Github issues.

Backport ANCM environment variable additions by BrennanConroy · Pull Request #20006 · dotnet/aspnetcore

Add switch to allow ANCM to prefer local environment variables over web.config environment variables. · Issue #19450 · dotnet/aspnetcore

Continue reading...
 
Top Bottom